Windows10で古いバージョンの.NET Frameworkを使う

 Windows10にウエブカメラのアプリをインストールしたときのことです。アプリをインストールすると「このセットアップは.NET Framework バージョン2.0.50727を必要としています。.NET Frameworkをインストールして、セットアップをやり直してください。.NET FrameworkはWebから取得できます。」とエラーが表示されました。古いアプリは、.NET Frameworkも古いバージョンを必要とすることがあります。
 window10にインストールされている.NET Frameworkは、バージョン 4.5以上になります。バージョン3以下を必要とするアプリは動かないので、古いバージョンをインストールすると解決できます。
 今回は、古いバージョンのインストール方法の紹介です。

アプリのエラー画面
net_framework

インストール手順

net_framework_2
 コントロールパネルを開き、「プログラムのアンインストール」をクリックします。上の画像は、コントロールパネルの表示方法を「カテゴリ」にしています。「アイコン」で表示すると表示方法が変わります。注意してください。

net_framework_3
 左側にある「Windowsの機能の有効化または無効化」をクリックします。

net_framework_4
 「.NET Framework3.5(.NET 2.0 および 3.0を含む)」の項目にチェックを入れ、「OK」をクリックします。

net_framework_5
 「Windows Updateからファイルをダウンロードする」をクリックする。
 以上で完了です。


 最近、OSをWinodws10へのアップグレードによる不具合の問合せが多くなっています。特に、アプリのライセンスを引き継げないケースが目立ちます。皆さんもアップグレードするときは、アプリの不具合が無いか確認した上で、アップグレードしてくださいね。

Be the first to comment on "Windows10で古いバージョンの.NET Frameworkを使う"

Leave a comment